WooCommerce Message: “Your theme does not declare WooCommerce support”

Posted in: , , ,
Please note: your WordPress theme is completely fine and still fully compatible with latest version of WooCommerce.

Overview:

If you’ve recently upgraded to or installed WooCommerce 2.0 then you might be receiving this message inside your WordPress Dashboard:

Your theme does not declare WooCommerce support – if you encounter layout issues please read our integration guide or choose a WooCommerce theme.

Simple Solution:

The fastest and easiest solution is to simply click on “Hide This Notice” button within the notification.

In-Depth Solution:

  1. Access Appearance > Editor
  2. Locate the functions.php file
  3. Add the following code at the very end of the file, just before the closing PHP Tag ?>
  4. Save and rejoice :)
add_theme_support('woocommerce');